Критические уязвимости в Vanilla Forums ставят под угрозу более 500 тыс. сайтов

Исследователь Давид Голунски (Dawid Golunski) предупредил о двух опасных уязвимостях в открытом форумном движке Vanilla Forums, использующемся на свыше 500 тыс. web-сайтов. Проэксплуатировав проблемы, неавторизованный атакующий может удаленно получить контроль над целевыми ресурсами.

Уязвимости CVE-2016-10033 (позволяет удаленно выполнить код) и CVE-2016-10073 (Host Header Injection) затрагивают последнюю версию движка — Vanilla Forums 2.3. По словам эксперта, уязвимости существуют в связи с тем, что в Vanilla Forums по-прежнему используется уязвимая версия популярной открытой PHP-библиотеки PHPMailer.

В минувшем году Голунски уже сообщал об уязвимости в PHPMailer, позволяющей злоумышленнику выполнить произвольный код в контексте web-сервера и полностью скомпрометировать целевое web-приложение. Эксперт опубликовал видео, в котором продемонстрировал, что эксплоит для вышеуказанной уязвимости в сочетании с проблемой CVE-2016-10073 может использоваться для внедрения произвольных команд в HTTP-заголовок HOST.

Злоумышленник может отдельно проэксплуатировать CVE-2016-10073 для компрометации учетной записи пользователя, например, администратора, путем отправки специально сформированного HTTP-заголовка HOST и иницировать сброс пароля для целевой учетной записи. Данная техника также может работать по схожему принципу с PoC-эксплоитом для уязвимости в WordPress, опубликованным Голунски на минувшей неделе.

Исследователь направил отчет об уязвимостях разработчикам Vanilla Forums в январе нынешнего года, однако спустя пять месяцев проблемы по-прежнему остаются неисправленными.

Источник: SecurityLab.ru



(adsbygoogle = window.adsbygoogle || ).push({});